Insights Reporting Unavailable

Incident Report for PFL.com

Resolved

Reports are loading as expected.
Posted Oct 21, 2025 - 12:23 MDT

Monitoring

Reports are loading successfully, although some require longer load times.
Posted Oct 21, 2025 - 10:49 MDT

Update

Microsoft is addressing the issue. We are seeing some reports loading successfully.
Posted Oct 21, 2025 - 10:40 MDT

Identified

Loading of reports in PFL Insights is failing to load due to an outage with Microsoft. The Microsoft issue is widespread and affecting many systems in the West US region.
Posted Oct 21, 2025 - 09:27 MDT
This incident affected: The App (Insights).