Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2022 - 07:00 MST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 16, 2022 - 16:03 MST
Scheduled
PFL’s IT services team is performing an infrastructure upgrade December 17th, 2022 from 7am to 11am. During this maintenance window all PFL resources will be offline for an estimated 4 hours. Orders submitted through our platforms will not be affected, however order status feedback may be delayed.
We appreciate your patience while we ensure uptime and stability remains a part of our continued success.
Posted Dec 16, 2022 - 16:01 MST
This scheduled maintenance affected: PFL DB (PPS, PFL Public Ordering Pages, MyPFL, PFL API), Salesforce TMA (Delivery Notification), PMC (Ordering, Delivery Notification), SwagIQ 2.0 (Delivery Notification), Command Center (My Products), and eGift.