Insights Status Updates Delyaed

Incident Report for PFL.com

Identified

The issue has been identified and a fix is being determined.
Posted May 05, 2026 - 15:27 MDT

Investigating

We are currently investigating an issue with status updates in Insights being delayed.
Posted May 05, 2026 - 12:11 MDT
This incident affects: The App (Insights).