Insights in the PFL App Not Loading

Incident Report for PFL.com

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 07:47 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2026 - 05:17 MDT

Update

The plan to remediate is being implemented.
Posted Jun 24, 2026 - 16:21 MDT

Identified

The issue has been identified. A plan to remediate the issue is being developed.
Posted Jun 24, 2026 - 14:21 MDT

Investigating

We are currently investigating the issue. Only general reports appear to be affected, however custom reports continue to function.
Posted Jun 24, 2026 - 13:23 MDT
This incident affected: The App (Insights).