Microsoft Outage Impacting PFL Insights

Incident Report for PFL.com

Monitoring

Microsoft has implemented a fix and we are continuing to monitor. Some updates in Insights may be delayed.
Posted May 18, 2026 - 14:49 MDT

Update

Microsoft has implemented a fix and we are continuing to monitor. Some updates in Insights may be delayed.
Posted May 18, 2026 - 14:49 MDT

Update

We are continuing to work on a fix for this issue.
Posted May 18, 2026 - 13:56 MDT

Identified

Due to a Microsoft outage, Insights in the PFL app may be intermittently unavailable. Microsoft is actively troubleshooting the issue.
Posted May 18, 2026 - 10:36 MDT
This incident affects: The App (Insights).