Status Update Delays

Incident Report for PFL.com

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2026 - 00:02 MDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 27, 2026 - 14:40 MDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 27, 2026 - 14:30 MDT

Identified

We are experiencing delayed status updates for orders placed this morning. We have identified the issue and working towards a resolution.
Posted Apr 27, 2026 - 13:58 MDT
This incident affects: Salesforce Marketing Cloud (Delivery Notification), TMA for Sales (Ordering, Delivery Notification, Customization), Eloqua (Delivery Notification), Marketo (Delivery Notification), The App (Insights), Iterable (Delivery Notification), SwagIQ 2.0 (Delivery Notification), PMC (Delivery Notification), and API Integrations, eGift.