Order Status Updates
Incident Report for PFL.com
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 08:53 MDT
Monitoring
A fix has been implemented. Status updates are beginning to flow and we are monitoring progress.
Posted Jun 03, 2024 - 21:00 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 03, 2024 - 11:28 MDT
Investigating
We are currently investigating the issue, status updates may be affected.
Posted Jun 03, 2024 - 11:12 MDT
This incident affected: Salesforce Marketing Cloud (Delivery Notification), Command Center (Order History), Eloqua (Delivery Notification), Marketo (Delivery Notification), The App (Insights), TMA for Sales (Delivery Notification), and PMC (Delivery Notification).