Intermittent System Degradation

Incident Report for PFL.com

Resolved

This incident has been resolved.
Posted May 12, 2025 - 10:34 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2025 - 09:56 MDT

Update

We are continuing to investigate this issue.
Posted May 12, 2025 - 09:52 MDT

Update

We are continuing to investigate this issue.
Posted May 12, 2025 - 09:29 MDT

Investigating

We are investigating the issue. We have verified that orders are continuing to be placed via automated platforms. Updates to follow.
Posted May 12, 2025 - 09:28 MDT
This incident affected: TMA for Sales (Product Selection, Ordering, Delivery Notification, Customization), PFL DB (PPS, MyPFL, PFL API), Salesforce Marketing Cloud (Delivery Notification), Eloqua (Delivery Notification), Marketo (Delivery Notification), SwagIQ 2.0 (Ordering, Delivery Notification, Customization), Salesforce TMA (Delivery Notification), Iterable (Delivery Notification), Command Center (Marketo Webhook Generator, My Products), PMC (Ordering, Delivery Notification, Customize Page), The App (Webhook Generator - Marketo, Webhook Generator - Iterable), and API Integrations, eGift, TestAPI.