The App is experiencing extended load times
Incident Report for PFL.com
Resolved
This incident has been resolved.
Posted May 24, 2024 - 10:48 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2024 - 10:18 MDT
Investigating
We are currently investigating this issue.
Posted May 24, 2024 - 09:40 MDT
This incident affected: The App (Insights, User Management, Notifications, Notifications - Admin, Webhook Generator - Marketo, Webhook Generator - Iterable).